↑ 画面不动?没声音?点这里!(教程

继上次的翻车之后,我算是有了些经验,同时机器上也装了些共通的依赖库,由于上项目最后的错误解决不了就放那里了,开始搞一下这个项目,这和上一个项目的目的是一样的,都是借助GPU进行加速计算的可视化工具,但此项目是用netbeans开发的,在文件结构上要比上一个复杂的多,而且采用的是CMakeList.txt的方式,应该算比较正式的C++项目了吧。

题外话:nvcc和nvidia-smi显示的cuda版本不一样

这个问题最终被确定和程序运行的错误无关,但碰巧发现了,总觉得不一样怪怪的,而不一样的原因其实很简单,可以理解为一个版本是程序用的软件运行的Cuda版本,而另一个是开发用的Cuda版本。更多内容可以参见这个帖子

具体来说,就是确保Cuda安装后添加PATH:添加Cuda Bin的$PATH(即将以下行添加到您的~/.bashrc)

1
export PATH=/usr/local/cuda-10.1/bin:/usr/local/cuda-10.1/NsightCompute-2019.1${PATH:+:${PATH}}

注意:确保首先存在以下两个路径:/usr/local/cuda-10.1/bin和/usr/local/cuda-10.1/NsightCompute-2019.1(NsightCompute路径的结尾可能略有不同,具体取决于安装的Nsight计算版本。
然后,更新$LD_LIBRARY_PATH(即添加以下行,在~/bashrc内)。

1
export LD_LIBRARY_PATH=/usr/local/cuda-10.1/lib64\${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}

在此之后,两者nvcc和nvidia-smi(或nvtop)就应该打印相同版本的Cuda了

尝试运行项目

构建这个项目,首先需要新建个cmake文件夹,然后进入该文件夹内,执行cmake命令,结果报错了,找不到Cuda(found 9.1),隐约感到这不是简单的路径问题,后来得到证实,这是在编译时没有指定版本导致的。

解决方案:在cmake时添加编译参数(参见这里),如下所示:

1
cmake -DCUDA_TOOLKIT_ROOT_DIR=/usr/local/cuda-10.2

常规的配置修改

修改arch参数,改为compute_50,由于是CMakeList.txt构建的,所以这次在这里修改。之后,修改对应的模块路径,修改简单的引用错误。

make系列错误

做完以上操作后,cmake命令就基本没问题了,这里我们需要继续make,但是make到[66%]左右时会出现错误如下,我以为又是什么难以解决的问题,结果在make之前clean一下就ok了。

注意make之前一定要make -clean,不然会出错,详见这里,修改玩上述报错后会有新错误:

链接时的recompile with -fPTC

可以看到已经编译完成了,但链接linking出错,在此,我推测是原有的静态链接文件(源代码带的)并不能在我的机器上正常工作,我需要重新编译生成一遍,之后我重新编译了ANN、Wordcloud、Cubu模块,发现大部分错误消失了,但又出现新错误,如下:

恼人的Cubu模块

定位:graphdrawing 有问题,进而定位到Cubu,非常怀疑是libcubu.a这个静态链接库有问题,但我重新编译后生成的新文件去替换它之后,会出现以下错误,

怀疑是Cubu的版本不对应,编译都不通过。用原来Cubu的include文件夹+新的libcubu.a,错误依旧:

用新的include文件夹+原来的libcubu.a,错误又会复现。基本确定是cubu重新编译的问题。原来的libcubu.a需要重新编译,但我现在编译出的静态链接文件libcubu.a又和原先的Cubu的版本好像不一样,所以导致上述错误。

卡壳了。



😒 留下您对该文章的评价 😄



 评论




全站共计 295.4k 字,自豪地使用 Volantis 主题

博客内容遵循 署名-非商业性使用-相同方式共享 4.0 国际 (CC BY-NC-SA 4.0) 协议